Service interruption on Intuit nightly backups
Incident Report for Rewind
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 09:19 EDT
Identified
Issue has been identified and backups are in progress for all accounts that were impacted by this service interruption. We will post an update once this is complete.
Posted Sep 07, 2021 - 11:53 EDT
Investigating
We are experiencing a service interruption to nightly backups for Intuit; action is underway to resume service, we will post an update as soon as one is available.
Posted Sep 07, 2021 - 10:37 EDT