Delayed backups on the BigCommerce backup in the US region
Incident Report for Rewind
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 22:14 EDT
Investigating
We are currently investigating an issue with Rewind Backups for BigCommerce in the US region.
Posted Sep 28, 2021 - 16:12 EDT
This incident affected: Rewind Automated Backups (BigCommerce).