Delayed backups for some customers in US region
Incident Report for Rewind
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 22:39 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 17:03 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2024 - 16:53 EDT
Investigating
We're investigating delayed backups for some customers in US region. Our team is on it!
Posted Jul 17, 2024 - 15:46 EDT
This incident affected: Backups.