Performance slowdown on the app and some backups
Incident Report for Rewind
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 16:46 EDT
Investigating
We are currently investigating a performance issue with our core internal api service.
Posted Mar 26, 2024 - 15:58 EDT
This incident affected: Rewind Web Application, Backups, and Restores.